Phone Line Issues
Incident Report for Register365 Status Page
Resolved
The issues with our phone lines have now been resolved. We apologise for any inconvenience caused and thank you for your patience.
Posted Apr 16, 2021 - 16:08 BST
Investigating
We're currently experiencing issues with our phone lines. This is being looked into as a matter of urgency and we hope to have them back up and running soon.
In the meantime, if you have an urgent query please drop us a message or raise a ticket from your Online Control Panel at https://login.register365.com/login and we will get back to you as quickly as possible.
Posted Apr 16, 2021 - 15:20 BST
This incident affected: Phone System.