Phone Line Issues
Incident Report for Register365 Status Page
Resolved
The issues with our phone lines have now been resolved. We apologise for any inconvenience caused and thank you for your patience.
Posted Apr 16, 2021 - 16:09 BST
Investigating
We are currently aware of an issue with the phone lines for our office, as a result the local 01905 numbers are not available. This is being investigated by our phone provider.
You can still reach our support teams on the following number - 01 5255768
Posted Apr 09, 2021 - 12:39 BST
This incident affected: Phone System.