Payment Processing Issue
Incident Report for Register365 Status Page
Resolved
This incident has been resolved.
Posted Aug 22, 2020 - 13:01 BST
Monitoring
Our payment provider has resolved their issues and payments have been completing since 20:50 this evening.

We will continue to monitor situation.
Posted Aug 21, 2020 - 22:46 BST
Update
We are continuing to communicate with our payment provider. Unfortunately they have still not been able to rectified their connectivity issues and cannot provide us with an ETA at this moment.
We will provide updates as we have them.

Sincere apologies for any inconvenience this is causing, as soon as our payment provider can resume services, we have people on hand to get our payment processing back up as soon as possible.
Posted Aug 21, 2020 - 19:53 BST
Update
Following an investigation by our payment provider, it appears they were experiencing a DDoS, which was causing connectivity issues between Register365 and their platform.

Initial steps taken by our payment provider have not rectified the connectivity issues. We are in communication with them to resume services as soon as possible
Posted Aug 21, 2020 - 16:59 BST
Investigating
We are aware that customers may be experiencing problems trying to purchase or renew products and services due to an issue processing payments.

We are investigating this as a matter of urgency and will update this notification when we have further information.

If you have any further queries regarding this, please create a support ticket through the "Technical Support" section of your Control Panel and we will be happy to assist further.
Posted Aug 21, 2020 - 16:14 BST