Degraded Network Status
Incident Report for Register365 Status Page
Resolved
This incident has been resolved.
Posted Nov 14, 2019 - 17:21 GMT
Investigating
We are currently experiencing network performance issues that may be impacting some customer website and email services. Our engineers are still investigating the root cause and we will update at the very first opportunity. Please accept our apologies for the inconvenience caused and be reassured that we are doing everything to restore a full service.
Posted Nov 14, 2019 - 12:22 GMT
This incident affected: Network.