Online Control Panel, File Manager and password changes
Incident Report for Register365 Status Page
Resolved
This incident has been resolved.
Posted Feb 06, 2024 - 17:41 GMT
Investigating
Some customers may be experiencing problems accessing the File Manager within their Online Control Panel, as well as the Webmail 1-Click Login links. Additionally, there may be a delay in password changes taking effect.

We are looking into this as a priority and apologise for any inconvenience it may be causing.
Posted Feb 06, 2024 - 16:10 GMT
This incident affected: Control Panel.