Sitemaker Websites and editors
Incident Report for Register365 Status Page
Resolved
The intermittent issue affecting some customers on our SiteMaker packages was identified and a fix released at 9.50am. This has been monitored since and no further issues reported.
We will continue to monitor it closely
Posted May 22, 2020 - 12:17 BST
Investigating
Websites and editors that use our SiteMaker packages may currently be displaying a Bad Gateway error or timeout. This is intermittent and subsequent refreshes of the page may cause it to display fine. We are investigating this, and apologise for any inconvenience.
Posted May 22, 2020 - 00:00 BST