Network maintenance

Scheduled for Mar 16, 20:00 - 23:30 GMT

Update

We doing work on some of infrastructure that fronts these services.
No impact expected, This will be an at risk period for the for the affected components, Website, Control Panel and Webmail.
Posted Mar 11, 2026 - 12:30 GMT

Scheduled

We are doing some preparation work for later works.
No impact expected, This will be an at risk period for the for the affected components, Website, Control Panel and Webmail.
Posted Mar 11, 2026 - 10:48 GMT
This scheduled maintenance affects: Control Panel, WebMail, and Website.