Problem with internal systems
Incident Report for Register365 Status Page
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 16, 2019 - 16:17 BST
Investigating
Due to a fault with our internal customer management system, we are unable to efficiently deal with telephone enquiries. Due to this, we recommend that customers create a Support ticket through their Control Panels, and we will respond back as soon as we can.
We apologise for any inconvenience this may cause.
Posted 3 months ago. Jul 16, 2019 - 15:52 BST