Telephone Lines down
Incident Report for Register365 Status Page
Resolved
Telephone lines are now back up and we look forward to speaking to you once more.
Posted Mar 26, 2024 - 10:54 GMT
Investigating
We are currently unable to receive incoming telephone calls to our Contact Centre. This has been reported to our telephone provider and is being investigated as a priority. For any urgent enquiries, please create a support enquiry through your Online Control Panel - our team is standing by ready to assist.

We will update this message once service has been restored.
Posted Mar 26, 2024 - 10:39 GMT
This incident affected: Phone System.