Problem with telephone lines

Incident Report for Register365 Status Page

Resolved

Phone lines are now operational. Thank you for your patience.
Posted May 12, 2026 - 13:35 BST

Update

We are continuing to investigate this issue.
Posted May 12, 2026 - 13:34 BST

Update

We are continuing to investigate this issue.
Posted May 12, 2026 - 12:24 BST

Investigating

Apologies if you're trying to contact us. We're currently experiencing a problem with our phone lines. Engineers are on the case but, in the meantime, please submit any urgent enquiries through your Online Control Panel, and we'll get back to you as quickly as we can.
Posted May 12, 2026 - 12:23 BST
This incident affected: Phone System.